Resorts & Lodging
Fishing Guides
Bait & Tackle Shops
Products & Services
Important Links
Classified Ads
Contact Us & More
Minnesota Fishing Reports






95 polaris magnum 425 4x4
LSF Member
Joined:
03/08/2013
From Ham Lake
Posts: 6
I just got a 1995 polaris magnum 425 and the left front tire is not engaging when you press the 4x4 button, which the guy I bought it from told me. Any advice. Thanks

Posted on: 2013/8/19 11:05
Transfer the post to other applications Transfer


Re: 95 polaris magnum 425 4x4
LSF Member
Joined:
12/07/2010
From St.Michael, New Ulm
Posts: 1481
Usually it is the wire from the switch to the Front Hubs that go out on Polaris's. I had a 2001 Polaris Magnum that did it. I took it to a shop and they had to resoder the wire back to the magnets on the Hub that wouldn't work.

I guess it also could be the clutches in the hub. They require special oil to be put in them. If this isn't kept up, they can go out also.

Good luck.

Posted on: 2013/8/19 11:31
Transfer the post to other applications Transfer


Re: 95 polaris magnum 425 4x4
LSF Member
Joined:
03/08/2013
From Ham Lake
Posts: 6
Thanks, I have to tear into it and see whats going on.

Posted on: 2013/8/20 8:30
Transfer the post to other applications Transfer







[Advanced Search]


 

 
Copyright 2004-2013 Lake State Fishing P.O. Box 577 Deerwood, MN 56444 612-414-5593
All logos and trademarks are property of their respective owners. |  Lake State Fishing |   Login lakestatefishing.com Facebook Page lakestatefishing.com Twitter Page lakestatefishing.com LinkedIn Page lakestatefishing.com YouTube Page