Resorts & Lodging
Fishing Guides
Bait & Tackle Shops
Products & Services
Important Links
Classified Ads
Contact Us & More
Minnesota Fishing Reports






1995 Mercury Black Max Question
LSF Member
Joined:
02/08/2011
Posts: 31
I've got a 95 Mercury Black Max EFI 175 hp that has always ran flawlessly with zero issues except one since it was purchased 4 years ago... I'm not sure if it is just the way these motors are, or if there is something I'm missing that needs to be looked at. Hoping I could get some insight.

When I get to the launch, the primer bulb has to be pumped or the motor will not get to the proper RPMs to keep running. Once I do this, run to a spot, turn the motor off and fish for a 30 minutes or so, the primer has to be pumped again or else the motor will "bog down" and quit running after taking off. Once I pump it, it is good to go and runs great.

I've been in tons of other guys' bass boats ranging from '95 to early 2000s and none of them have to pump the bulb to get their motor to run right away when they get to the launch, let alone pump it at all on the water. Is this just the way these 95 EFI's run and there's nothing I can do?

We've replaced the bulb & hose, anti-siphon valves 2 years ago, new Mercury starter & ignition and just paid to replace the fuel pump which the place we brought it to said was the issue and it "runs good now". If anyone has any other ideas or information, I would really appreciate it. This is a little bit of a hassle when tournament fishing moving from spot to spot!

Posted on: 5/17 21:40:05
Transfer the post to other applications Transfer


Re: 1995 Mercury Black Max Question
LSF Member
Joined:
01/09/2008
From Mn
Posts: 3109
qoute from you >>just paid to replace the fuel pump which the place we brought it to said was the issue and it "runs good now"

Sounds the problem is or isnt solved? I dont work on Mercs cause of costs of parts and hard to solve problems.Do you still have the loss of prime problem??
New fuel line,have you tried a different fuel tank? If I'm not mistaken Mercs have o-rings on each end of the fuel line have you replaced them?

Posted on: 5/18 17:46:03
_________________
Of all the things I've ever done,
I aint never had Too much fun.
Transfer the post to other applications Transfer


Re: 1995 Mercury Black Max Question
LSF Member
Joined:
02/08/2011
Posts: 31
What I meant to say was that the repair shop was mistaken and it does not "run good". Still had problem today. They hooked it up to a different fuel tank in order to make sure it was the motor and not the gas line. I am assuming they replaced the o rings but I should call them and make sure.

Posted on: 5/18 21:44:47
Transfer the post to other applications Transfer







[Advanced Search]


 

 
Copyright 2004-2013 Lake State Fishing P.O. Box 577 Deerwood, MN 56444 612-414-5593
All logos and trademarks are property of their respective owners. |  Lake State Fishing |   Login lakestatefishing.com Facebook Page lakestatefishing.com Twitter Page lakestatefishing.com LinkedIn Page lakestatefishing.com YouTube Page